Pre-2013 Amazon Kindle devices need mandatory update to remain online

Posted on Tuesday, Mar 22 2016 @ 16:06 CET by Thomas De Maesschalck
Amazon logo
Amazon recently rolled out a critical update for it pre-2013 Kindle eReaders. The installation of this update is mandatory, otherwise you'll be unable to connect to the web. You will no longer be able to access the Kindle Store, access your books in the cloud, etc.
Important: If you do not update your device by March 22, 2016, you will receive the following message on your device: Your Kindle is unable to connect at this time. Please make sure you are within wireless range and try again. If the problem persists, please restart your Kindle from the Menu in Settings and try again. If you see this message on your device on or after March 22, you will need to manually install the latest software update for your device. Go to Fire & Kindle Software Updates for more details.
Details on how to get the update on your device can be read at Amazon.


About the Author

Thomas De Maesschalck

Thomas has been messing with computer since early childhood and firmly believes the Internet is the best thing since sliced bread. Enjoys playing with new tech, is fascinated by science, and passionate about financial markets. When not behind a computer, he can be found with running shoes on or lifting heavy weights in the weight room.



Loading Comments