Why the Nintendo Wii browser only supports Flash 7

Posted on Monday, Apr 16 2007 @ 03:12 CEST by Thomas De Maesschalck
An Opera developer explained on his blog why the new Opera-based Internet Channel on the Nintendo Wii doesn't support Flash 8 and 9:
The answer is simple: there is no way to do so. It is out of both Opera and Nintendo's hands.

The latest version of the Flash SDK (Software Development Kit) offered by Adobe is version 7, so that's what anyone who is not a Windows, Linux or Mac PC have to settle with. To support Flash on a phone or device, you have to license the Flash SDK from Adobe, and as long as they do not provide a more recent version, there is nothing you can do.

If Adobe had offered a more recent version, no one would have been more thrilled than us. It would have made more sites work, and that would lead to less frustration to our users.


About the Author

Thomas De Maesschalck

Thomas has been messing with computer since early childhood and firmly believes the Internet is the best thing since sliced bread. Enjoys playing with new tech, is fascinated by science, and passionate about financial markets. When not behind a computer, he can be found with running shoes on or lifting heavy weights in the weight room.



Loading Comments